Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: Abarth 500 heater only blowing cold air  (Read 200 times)

Offline Mattgill123

  • Abarth Wannabe
  • *
  • Posts: 15
  • Carlo Rating: 0
    • Wigan
Abarth 500 heater only blowing cold air
« on: October 17, 2020, 09:04:09 am »
Wondering if anyone can help driving my car this morning and heater is only blowing cold air no warm is coming thru ac is working fine. Engine coolant is fine wondering if anyone can point me in right direction

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline Richard H

    • Assetto Corse Member
    • ****
    • Posts: 428
    • Carlo Rating: 3
      • North Herts
    Re: Abarth 500 heater only blowing cold air
    « Reply #1 on: October 17, 2020, 02:00:34 pm »
    Its probably a problem with the flaps in the system that direct the warm air in to the cabin.

    It could be the flaps are stuck, or it could be the actuator

    You'll probably have to take a lot of dash out to find it

    Offline skidbarth

    • Abarth Wannabe
    • *
    • Posts: 33
    • Carlo Rating: 0
      • Melbourne, VIC, Oz
    Re: Abarth 500 heater only blowing cold air
    « Reply #2 on: October 23, 2020, 09:29:44 am »
    I have the reverse of this problem - blowing cold only.

    Research on the interweb tells me that it's common(ish) with Fiat 500/Pandas with the climate control system, especially if you run the control frequently to the full "Lo" or full "Hi" setting - the motor over-extends the flap in the hot/cold mixer (there's no heater tap) and the flap breaks off the actuator at whatever extreme it's at.

    Now, in the UK, there's a specialist that claims to have a fix for this: https://smallcarservices.co.uk/

    Assuming you're in the UK, you'll be able to figure your distance to there and if it's worth the trip.

    If you're not, or want to go DIY, there's the following thread on a Fiat forum (including posts from the above garage owner): https://www.fiatforum.com/panda/463031-100hp-heater-playing-tricks-me-help-3.html ...and scroll down to post 36, where the fun starts. To be clear, the motor the photos are of are on the RHS.

    Now, note this is for a Panda, which is as I understand it, the source model for our Abarths. The bit of exploratory investigating I did on our car makes me think that once you get to the heater motor it's identical.  And, with some painful contortions I can feel the motor driving the control cog, but no temp change (so my flap is broken from the motor).

    But, in my car, the knee airbag looks to be in the way. I *think* it's only 2 bolts to remove it BUT I have never serviced an airbag and don't want to shoot myself in the foot. Or face. With an airbag. So still contemplating next steps.

    Hope that helps. Would also welcome any thoughts from anyone with airbag servicing experience!


    Offline skidbarth

    • Abarth Wannabe
    • *
    • Posts: 33
    • Carlo Rating: 0
      • Melbourne, VIC, Oz
    Re: Abarth 500 heater only blowing cold air
    « Reply #3 on: October 23, 2020, 12:46:22 pm »
    Err sorry should have said I have SAME problem as OP...