Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: Boot opening issue  (Read 924 times)

Offline soutermcgavin

  • Abarth Wannabe
  • *
  • Posts: 17
  • Carlo Rating: 0
    • Dunfermline
Boot opening issue
« on: February 21, 2019, 07:24:37 am »
Hi all,
At the moment my boot will only unlock using the button on the key. If I just unlock the car and use the boot catch with my hand it doesn’t open.
Has anyone experienced this at all?
Any advice on the problem and the solution?
Thanks
Murray

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline Filthypig

    • S2000 Member
    • *****
    • Posts: 716
    • Carlo Rating: 1
    Re: Boot opening issue
    « Reply #1 on: February 21, 2019, 07:13:24 pm »
    The wiring will have frayed where it comes through to the boot. Only fix is to repair the wires and it'll work again. You can get repair harnesses online so if your handy with a soldering kit you can fix easily yourself.

    Otherwise its off to an autoelectrician to sort.

    Offline Richard H

    • Assetto Corse Member
    • ****
    • Posts: 424
    • Carlo Rating: 3
      • North Herts
    Re: Boot opening issue
    « Reply #2 on: February 22, 2019, 09:06:43 pm »
    Its often the wiring issue.

    We had the same and it was the switch on the boot itself and the chrome switch/handle were replaced under warranty

    Offline Borderline

    • Abarth Wannabe
    • *
    • Posts: 25
    • Carlo Rating: 0
      • Scottish Borders
    Re: Boot opening issue
    « Reply #3 on: March 02, 2019, 04:06:34 pm »
    Apparently this a well-known issue with all versions of the 500. It's worth trying a little trick before replacing the switch or indeed the wiring. Use a can of compressed air (sold online for cleaning keyboards) to have a good blast around the flap you squeeze to open the boot. The theory is that the switch under the flap gets bunged up with all sorts of road grot and blowing it out may help. This worked on my previous (Fiat) 500 and I'm about to try it on the Abarth (as soon as it stops raining...)

    Offline NateM

    • Newbie
    • *
    • Posts: 4
    • Carlo Rating: 0
      • High Wycombe
    Re: Boot opening issue
    « Reply #4 on: February 14, 2020, 08:39:02 am »
    Great advice, did it work on your Abarth?

    I've had this problem for years and yes, Abarth dealers said new wiring loom at extortionate costs.

    Offline Moose

    • S2000 Member
    • *****
    • Posts: 625
    • Carlo Rating: 0
    Re: Boot opening issue
    « Reply #5 on: February 25, 2020, 09:17:25 pm »
    If it's only the boot catch that doesn't work (ie you can open it with your key) then it's more than likely that the switch pins have worked loose - I have the same issue now and I've yet to fix it, but I think I found a youtube video somewhere. If I find it again, I'll post the link
    Scorpion Black/Gara White Bi-Colour A595 Turismo, black leather and Interscope

    Crossover Black, black leather, white stripes, mirrors and scorpion - Gone, but not forgotten

    Offline R34

    • Assetto Corse Member
    • ****
    • Posts: 303
    • Carlo Rating: 1
      • Costa del sol
    Re: Boot opening issue
    « Reply #6 on: February 26, 2020, 11:19:42 pm »
    Easy repair

    Offline Moose

    • S2000 Member
    • *****
    • Posts: 625
    • Carlo Rating: 0
    Re: Boot opening issue
    « Reply #7 on: February 27, 2020, 07:51:13 pm »
    Youtube vid

    Scorpion Black/Gara White Bi-Colour A595 Turismo, black leather and Interscope

    Crossover Black, black leather, white stripes, mirrors and scorpion - Gone, but not forgotten

     

    hungry