Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: Engine shuts down (Abarth 595 comp)  (Read 542 times)

Offline bob101

  • Newbie
  • *
  • Posts: 2
  • Carlo Rating: 0
Engine shuts down (Abarth 595 comp)
« on: November 15, 2021, 09:29:40 am »
Hi All,

I purchased a Abarth 595 comp in May this year. It has an issue with cutting out whilst driving :/.

The first sign of this issue was on longer drips along the motorway (I thought it could be an overheating issue) but then it started frequently on short journeys also.

The issue = push accelerator = temp gauge flys top top / Battery light on / all symbols show / engine shuts off, then when you turn off on again it seems fine.... 

I have replaced the battery / flushed and replaced the radiator coolant / replaced the temp sensor (Which seemed to have made the issue happen less regularly but I did all the changes at one time so who knows).

There is no error codes showing on the diagnostics .  I have spoke to aforalpha  and they have suggested  it could be a connection issue cutting power to ECU or engine earth on gearbox?

Just wondering if anyone has had a simliar issue?


Thanks

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline mj2k

    • Esseesse Member
    • ***
    • Posts: 130
    • Carlo Rating: 1
    Re: Engine shuts down (Abarth 595 comp)
    « Reply #1 on: November 15, 2021, 10:01:17 am »
    Hi and welcome :)

    Not had it myself (but then my car's still in bits) but I have read about other people having very weird issues with an iffy gearbox ground, so well worthwhile starting your investigations there, and continue on with a general look at the grounds.

    Offline bob101

    • Newbie
    • *
    • Posts: 2
    • Carlo Rating: 0
    Re: Engine shuts down (Abarth 595 comp)
    « Reply #2 on: November 15, 2021, 01:07:39 pm »
    Thanks for the welcome and input. It will be going into the garage on Thursday so hopefully they can get to the bottom of it!

     

    hungry