Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: MTA paddle issues  (Read 351 times)

Offline Spewy1

  • Abarth Wannabe
  • *
  • Posts: 12
  • Carlo Rating: 0
    • Cheshire
MTA paddle issues
« on: December 13, 2021, 09:48:46 pm »
Anyone with an mta version had problems with the paddles not responding.

Happened on mine a few weeks ago. Put it back in auto for a a while then the paddles (the + side) started working again. Been fine until today when it failed again.
Again put it back in auto for a few miles. Switched back to manual and the paddle is working fine again.

Any ideas?
It's still under warranty so I think I will probably have to have it looked at unless anyone is aware of a quick fix?

It's a 2021 Competizione BTW.

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline jl-c

    • Abarth Wannabe
    • *
    • Posts: 30
    • Carlo Rating: 0
    • Always learning !
      • Shropshire
    Re: MTA paddle issues
    « Reply #1 on: December 14, 2021, 11:04:05 am »
    I would guess at a bad connection on the clock spring under the steering wheel. Let them sort it, getting airbags out is relatively easy if you know what you are doing but as it is new, throw it back to them.
    Abarth 500C MTA , Audi S4 Quattro Avant , Porsche 911S

    Offline mj2k

    • Esseesse Member
    • ***
    • Posts: 128
    • Carlo Rating: 1
    Re: MTA paddle issues
    « Reply #2 on: December 14, 2021, 11:22:01 am »
    Agree with this ^ 100%. Even if it is something v simple you should throw it back to the dealer, otherwise you risk voiding your warranty.

    Offline Spewy1

    • Abarth Wannabe
    • *
    • Posts: 12
    • Carlo Rating: 0
      • Cheshire
    Re: MTA paddle issues
    « Reply #3 on: December 14, 2021, 01:40:17 pm »
    I tend to agree that it is likely some sort or poor connection issue but strange how it seems OK after a while of driving  in auto.
    I was wondering if I should only switch modes whilst stationary as I have been changing whilst in motion. Maybe that confuses the computer? I have been out in it again today and turned manual on before setting off and it's worked flawlessly today.

    One reason I am avoiding taking back to the local dealer is that it is not that local and they have a bad reputation but I suppose I have no choice (are they obliged to provide a loan car while they have mine in?)

     

    hungry