Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: New Abarth Turbo Failure  (Read 2113 times)

Offline safetyen

  • Abarth Wannabe
  • *
  • Posts: 8
  • Carlo Rating: 0
    • South London
New Abarth Turbo Failure
« on: August 07, 2012, 10:41:58 pm »
Picked up my new 500 Abarth less than a week ago and with 320 miles on the clock the Turbo has gone - NOT IMPRESSED!! No boost showing on the gauge, no power, and at 2000 rpm wheezes loudly!! :'( :'(


AbarthForum.co.uk

  • Advertisement
  • ***

    Offline lloyd

    • S2000 Member
    • *****
    • Posts: 9336
    • Carlo Rating: 24
    Re: New Abarth Turbo Failure
    « Reply #1 on: August 07, 2012, 10:53:04 pm »
    urgent call to dealer, it will be fixed :thumb:

    Offline biancodiablo

    • S2000 Member
    • *****
    • Posts: 960
    • Carlo Rating: 2
    Re: New Abarth Turbo Failure
    « Reply #2 on: August 08, 2012, 07:24:11 am »
    ..... sounds like a pipe somewhere has come off , dealer will fix it

    Offline On and on

    • Esseesse Member
    • ***
    • Posts: 138
    • Carlo Rating: 0
      • Fleet,Hampshire,UK
    Re: New Abarth Turbo Failure
    « Reply #3 on: August 08, 2012, 09:38:29 am »
    Sounds like a boost pipe has popped off. it can happen on new cars, as it did with my one of mine when it had 9 miles on the trip computer.

    Offline Trooper

    • S2000 Member
    • *****
    • Posts: 3467
    • Carlo Rating: 13
    Re: New Abarth Turbo Failure
    « Reply #4 on: August 08, 2012, 04:44:11 pm »
    The sound you describe is more than likely a boost hose that has come loose, Hose clips sometimes fail/not fixed correctly.

    Im sure it will be back to normal in no time  :thumb:

    Offline rare

    • Assetto Corse Member
    • ****
    • Posts: 455
    • Carlo Rating: 1
    Re: New Abarth Turbo Failure
    « Reply #5 on: August 11, 2012, 01:35:43 pm »
    I would be massively supprised if it was a turbo failure. They are extremely robust! Most certainly a pipe. The clips they use from factory are a bit naff.
    2010 - A500/TMC/MONZA/GTT Level 2 - Sold
    2015 - 595 Comp 180

    Offline safetyen

    • Abarth Wannabe
    • *
    • Posts: 8
    • Carlo Rating: 0
      • South London
    Re: New Abarth Turbo Failure
    « Reply #6 on: August 16, 2012, 05:44:37 pm »
    Thanks for comments, it was the clip on the pipe from the intercooler to the inlet manifold. All now OK.  :wave:

    Offline rare

    • Assetto Corse Member
    • ****
    • Posts: 455
    • Carlo Rating: 1
    Re: New Abarth Turbo Failure
    « Reply #7 on: August 16, 2012, 07:16:08 pm »
    Surprise surprise, what did I tell you, naff clips :thumbd: Glad you got it all fixed, enjoy :)
    2010 - A500/TMC/MONZA/GTT Level 2 - Sold
    2015 - 595 Comp 180