Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: No ignition / lights / dashboard  (Read 1514 times)

Offline martin0852

  • Abarth Wannabe
  • *
  • Posts: 8
  • Carlo Rating: 0
    • Ireland
No ignition / lights / dashboard
« on: October 11, 2016, 09:38:52 am »
Hi All,

I'm having a slight issue with my 2011 500 abarth in that it won't start :(. By "won't start" I mean no attempt to start from turning the key. There's absolutely no lights in the instrument cluster Except for when I open or close the doors. When I do this the clock comes up looking to be reset along with the mileage, then disappears after 10 seconds. I have radio, hazards, interior lighting and parks but nothing else.

How I came to this situation was after swapping exhaust backbox I removed passenger side brake light to swap a bulb and there is a posssibty that there was a short circuit during messing about with it. This is likely as the parks died while light was out of lens /housing.

After this I pulled a fuse, before checking the dash to see if ignition was on (I know, should have checked beforehand :/) when I checked I saw nothing so removed the key and assumed no problem, disconnected battery and continued checking fuses.

I've checked fuses in passenger side interior - all ok
Fuses in engine compartment - all ok
Relays - removed all, inspected and gave a light tap and replaced(cross swapped a few also)

I've also read somewhere about a sequence to reset ECU which involves disconnecting battery, wait ten mins, turn key, wait a minute, remove key, start(I stopped here :))

I bought the car from a dealer in Ireland and the original seller seems to be rockingham cars.

I'll try the dealer in Ireland first but I said I'd ask here as maybe he guys have seen this before?

No lights of any sort on dash I.e. No codes or anything / no check engine lights

I do have some stuff in the book about fiat codes but that says there will be a request via light on dash for this, which is not showing.

Also have retaina details but not sure what to do with them??? Is this an immobiliser issue maybe?

Any/all help greatly appreciated.

M

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline Shant Ole

    • S2000 Member
    • *****
    • Posts: 898
    • Carlo Rating: 1
      • Larnaca
    Re: No ignition / lights / dashboard
    « Reply #1 on: November 12, 2019, 12:06:05 am »
    I have the same issue with mine and i dont know what the problem is.

    Any news with yours?

    Offline Gregi

    • Esseesse Member
    • ***
    • Posts: 126
    • Carlo Rating: 4
      • Krak√≥w, Poland
    Re: No ignition / lights / dashboard
    « Reply #2 on: January 18, 2020, 10:37:33 pm »
    Did you check wiring loom between rear doors/boot lid and bodywork?
    '18 Abarth 595 Pista / Campovolo Grey
    ex '13 Abarth 500 Esseesse / White Gara

     

    hungry