Abarthisti

Abarth Cars => Abarth 500 => Topic started by: dougie on March 20, 2014, 01:36:41 pm

Title: problem with instrument panel lights-please help
Post by: dougie on March 20, 2014, 01:36:41 pm
Just had my first service on my 595 at arnold clark fiat and they noticed that the warning lights for the airbags were showing a dim light when the car is running, they light up brightly when the ignition is on but when they go out you can still see a faint glow from them, arnolds say they think they had a similar problem on a fiat 500 which they did under warranty.

As they are not an abarth dealer they can't do mine and i was wondering if anyone else has had this happen, or what the problem is, before i take it up as a warranty issue.

By the way arnolds did alot more than an oil and filter change which i was thinking they would do. i was quite happy as i have a service plan with them so it was paid for  :)

Thanks in advance for any help you can give me,

dougie
Title: Re: problem with instrument panel lights-please help
Post by: J_a_m_e_s on March 20, 2014, 03:24:43 pm
Seems they did one to a F500 didn't they tell you what the problem was?
Title: Re: problem with instrument panel lights-please help
Post by: dougie on March 20, 2014, 03:43:09 pm
No, the girl on the service reception said she thought they replaced the panel. its been like that for ages, i thought it was a trick of the light in sunny weather.
Title: Re: problem with instrument panel lights-please help
Post by: smallman28 on March 21, 2014, 04:21:30 pm
Surprised they even serviced it.
A local Fiat dealer wouldnt even do a service on mine.
I said it was a bit daft they didnt want to do the work as just a garage but they just kept saying they dont work ob Abarth.
Title: Re: problem with instrument panel lights-please help
Post by: dougie on March 21, 2014, 07:07:11 pm
I bought my car as a pre reg fom arnold clark fiat, they had it shipped down from their abarth dealership in scotland and i took out a service plan with them, i thought it was good value at £359 for 3 years servicing and first MOT.

I was surprised at the work they did at the first sevice, i was only expecting an oil and filter change but i got an 18000 mile service from them, after 2500 miles!! and a free winter pack. They were going to change the air filter but discovered it was the one abarth supplied and thought i had fitted an aftermarket one so they left it.

dougie
Title: Re: problem with instrument panel lights-please help
Post by: Dicanio10 on March 25, 2014, 08:06:32 pm
It will be the instrument cluster, known fault at the moment lots being changed
Title: Re: problem with instrument panel lights-please help
Post by: dougie on March 26, 2014, 12:03:01 am
Dicanio10, thanks for your reply, i'm surprised nobody else on here has had this problem and that my local fiat dealer has only replaced one under warranty. I will take it up with the nearest abarth dealership to me in manchester, although the lights are no longer staying on at the moment!!. I can only hope they are aware of the problem.


dougie
Title: Re: problem with instrument panel lights-please help
Post by: John501 on March 31, 2014, 02:13:39 pm
After a quick look at the service computer it is known fault.
It requires a complete replacement of the instrument cluster.
Title: Re: problem with instrument panel lights-please help
Post by: dougie on March 31, 2014, 07:51:22 pm
Thanks John,  cluster is behaving at the moment and the light is still not showing  i have a few warranty issues now so i will contact the Manhester dealer. Only ever had one warranty problem before and that was on a golf GTI back in 1989, i love abarth!!

dougie
Title: Re: problem with instrument panel lights-please help
Post by: Emmabell on July 14, 2020, 11:50:29 am
Hey everyone, I know this is an old post but I struggled to find much info, hopefully I can help others if they see this. I had some dim lights on my instrument panel too and Fiat quoted me a ridiculous price to get me a new panel which I wasn't willing to pay! Anyway, I found a company in Hampshire called Cartronix who fixed this problem for me for a lot cheaper! I drove my car to them and they repaired it in about an hour, I haven't had any issues since either. :D