Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: turbo blown.  (Read 796 times)

Offline rowen16

  • Newbie
  • *
  • Posts: 2
  • Carlo Rating: 0
turbo blown.
« on: August 03, 2021, 06:04:50 pm »
a bit easy I know but, a few weeks ago my standard Abarth 500 was losing power but not complete into limp mode. I took it to an independent garage who basically took the engine apart after saying it was the turbo. the turbo was sent away and the diagnosis was that oil was getting into the turbo. so after a £400 refurb. its all back together again, I took it for a 40 mile drive and 20 miles in engine management light came on and it went into limp mode -  lack of power in the turbo again. I took to the garage again they cleared engine management light and took it for a test drive and it seems ok. But im still frightened to actually drive the car in case this happens again. is it really possible that now the ecu faults have been cleared that it will be ok to drive or are Abarth 500's popular for having rubbish engines and turbo's and really I should just get rid of it? any feedback would be great thank you.

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline 695C

    • Esseesse Member
    • ***
    • Posts: 158
    • Carlo Rating: 1
      • Denmark
    Re: turbo blown.
    « Reply #1 on: August 07, 2021, 03:41:47 pm »
    Go and drive the car, if it goes into limp mode it could just be a hose that is not connected correctly and the turbo is not able to build pressure.