Abarthisti

Abarth Cars => Abarth 500 => Topic started by: Jaystoy500 on February 22, 2020, 08:57:10 am

Title: Brand New Abarth 595 Failure to Start, Misfiring & Stalling
Post by: Jaystoy500 on February 22, 2020, 08:57:10 am
I am having issues with my brand new Abarth 595 in Perth. Fails to start when first start of the day and it’s spring summer in aus so not cold. Stalls after second start attempt, runs rough and miss fires. Has done it since it only had 10km on clock. Has been back to the dealership so many times they can’t figure it out or say they fixed it then it faults again. They have replaces spark plugs and done so many other things. The car currently only has 4,000km on the clock as it has been in and out of dealer from new for last 4 months. Currently have Kevin Flynn the ceo of FCA australia coming to my house next week with all the managed to cold start it and test drive it over 3 days. Please not this is already a faulty replacement from another faulty from new 500x! Anyone had same issues that can email me some advice or what happened to theirs so I am ready when the big guns show up to my house.
Title: Re: Brand New Abarth 595 Failure to Start, Misfiring & Stalling
Post by: mac1944 on February 22, 2020, 09:58:45 am
Do you allow the speedo panel to boot up and warning lights go out before turning key to start
Title: Re: Brand New Abarth 595 Failure to Start, Misfiring & Stalling
Post by: GTMartin on March 01, 2020, 08:37:17 am
IIRC there were previous posts of issues with cars in your neck of the woods. The quality of petrol seems to spring to mind. Have a search they might help you.