Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: AGP EsseEsse Exhaust problem  (Read 1948 times)

Offline AGP2009

  • Esseesse Member
  • ***
  • Posts: 168
  • Carlo Rating: 0
AGP EsseEsse Exhaust problem
« on: September 10, 2009, 04:25:41 pm »
Hi Guys,

Has anyone had a problem with the esseesse exhaust since theres has been fitted in perticular the clamp that they use to join the new backbox, its just I had to have the AA out today as it completely came off pretty much, not that good considering it's only been fitted two weeks.

I seem to be having a few problems with the car lately seems every time something gets fixed something else breaks, I would'nt mind so much if the dealer did'nt need it for a day each time with no courtesy car.

AbarthForum.co.uk

  • Advertisement
  • ***

    wampa

    • Guest
    Re: AGP EsseEsse Exhaust problem
    « Reply #1 on: September 10, 2009, 05:17:57 pm »
    No Courtesy car is a real bind! Who have you been going to?

    Offline Missing in Action

    • S2000 Member
    • *****
    • Posts: 2974
    • Carlo Rating: 0
    Re: AGP EsseEsse Exhaust problem
    « Reply #2 on: September 11, 2009, 06:25:18 am »
    hmmm now who else did this happen to!........ possiably lloyd, not good  :thumbd:
    The one with the cape!

    Offline will

    • Esseesse Member
    • ***
    • Posts: 111
    • Carlo Rating: 0
    Re: AGP EsseEsse Exhaust problem
    « Reply #3 on: September 11, 2009, 11:21:01 am »
    thats exactly what happened to me, makes a horrible whooshing noise, as if the boot was open and whenever the vehicle moves a little bit, or goes over a bump there is a terrible rattle as if the whole exhaust is about the fall off. to top it off i had to pay £60 to have the clamp GLUED!!!!! back on, it should have been under warranty. absolute BOL***KS
    500c - Black/White two-tone, Monza

    Offline lloyd

    • S2000 Member
    • *****
    • Posts: 9336
    • Carlo Rating: 24
    Re: AGP EsseEsse Exhaust problem
    « Reply #4 on: September 11, 2009, 03:52:05 pm »
    wasn,t me, mine had a bit of a rattle which cured itself after a bit of running, must have just bedded in

    Offline cb500t

    • Assetto Corse Member
    • ****
    • Posts: 276
    • Carlo Rating: 0
    Re: AGP EsseEsse Exhaust problem
    « Reply #5 on: September 12, 2009, 03:54:58 pm »
    The loosening/coming off situation,is this due to design errors or hamfisted/inept technicians?

    Offline John501

    • Abarth Dealer
    • Dealer Liaison
    • S2000 Member
    • *****
    • Posts: 7448
    • Carlo Rating: 15
    Re: AGP EsseEsse Exhaust problem
    « Reply #6 on: September 14, 2009, 09:47:38 am »
    There has been 2 reported faults with the back boxes on AGP Esse Esse.
    There has been a small amount of back boxes with a manufacturing fault that means they coke up very quickly and block causing back pressure and blowing the box off. (My second Esse Esse had this problem)
    The second problem does look like a design error in the clamp that joins the 2 pipes together. The 2 pipes are different diameters and the clamp that is fitted only has one tightening device in the middle. It looks like these clamps tend to work loose and hence the back box comes away.
    The design fault has been now been reported to Turin and a couple of normal exhaust clamps on either end of the sleeve looks like it will solve the problem.
    Visit Vospers Abarth, Plymouth

    Offline cb500t

    • Assetto Corse Member
    • ****
    • Posts: 276
    • Carlo Rating: 0
    Re: AGP EsseEsse Exhaust problem
    « Reply #7 on: September 14, 2009, 10:05:32 am »
    Well if its just clamps  :lala: sorted...

    Offline A84RTH

    • S2000 Member
    • *****
    • Posts: 910
    • Carlo Rating: 0
    Re: AGP EsseEsse Exhaust problem
    « Reply #8 on: September 16, 2009, 07:58:11 pm »
    we had the same happen on ours, noticed it had a slight blow a few days after we left the dealers. Took it to a garage near us & for some reason when the fit the exhaust they just use one clamp right on the connection between the back box & centre pipe, we have had ours sleeved & now has a double clamp & its fine.
    :)Kim & Anthony:)
    BMW 335i 309bhp at the wheels, 572nm of torque :-)

    Offline AGP2009

    • Esseesse Member
    • ***
    • Posts: 168
    • Carlo Rating: 0
    Re: AGP EsseEsse Exhaust problem
    « Reply #9 on: September 18, 2009, 02:28:27 pm »
    Well like john said they have replaced the clamp and all seems well no loud roar any more and everything is working well :D