Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: Help - Gears not working properly  (Read 2143 times)

Offline Shant Ole

  • S2000 Member
  • *****
  • Posts: 898
  • Carlo Rating: 1
    • Larnaca
Help - Gears not working properly
« on: April 24, 2014, 03:37:21 pm »
I have a Grande Punto Van as a company car and since some of the parts are the same with the Abarth i thought to share my problem here and see if i can get any help.

Its been a while that the gears are not working properly. Sometimes they get stiff so i cant select first gear and reverse. Reverse is really bad though.
Two days ago i had trouble while driving and i had to stop the car. The gear wire had snapped and the gears were so stiff i couldnt select any of them.
I thought that was causing it but it looks like it was only another problem. Im thinking it might be clutch problems but im not too sure as its working okay and its not showing any bad signs.
Another thing might be the clutch pump. But im not sure.

I feel the gears are not normal as they get quite stiff from time to time and selecting reverse is a nightmare. I am being forced to turn off the car put reverse and then start the car again.

Any of you have experienced the same problem or know whats causing it?

I would really appreciate if i got some tips.

Thanks,

Shant


AbarthForum.co.uk

  • Advertisement
  • ***

    Offline will-w

    • S2000 Member
    • *****
    • Posts: 2287
    • Carlo Rating: 8
    • 'Captain Slow'
      • Kent
    Re: Help - Gears not working properly
    « Reply #1 on: April 24, 2014, 03:53:33 pm »
    I didn't know they were the same...  Has your van got the 6 speed M32 gearbox in it then?

    Apart from changing the fluids and getting a garage to check the master & slave cylinders there's not a lot I can suggest.

    How many miles has the van done?  Is it on it's original clutch?
    Abarth Punto Supersport
    Grigio Campovolo, Assetto Koni, Esseesse floating brakes, Skydome
    Summer: Gunmetal 18" Esseesse with Bridgestone Potenza RE050A
    Winter: Official Abarth Winter Kit (17" with Pirelli Sottozero 210)

    Offline 124Abarthreplica

    • Administrator
    • S2000 Member
    • *****
    • Posts: 2294
    • Carlo Rating: 13
      • Southampton
    Re: Help - Gears not working properly
    « Reply #2 on: April 24, 2014, 04:17:25 pm »
    So have you renewed the gear change cables?

    If you have and they are adjusted correctly then the clutch would be next on the list.

    Does the clutch free off the drive when depressed ie. does it drag?

    Where is the bite point, on the floor or up high?

    As it's hydraulic and self adjusting, apart from bleeding, unless something is loose or leaking then it's replacement parts

    Offline Shant Ole

    • S2000 Member
    • *****
    • Posts: 898
    • Carlo Rating: 1
      • Larnaca
    Re: Help - Gears not working properly
    « Reply #3 on: April 24, 2014, 04:42:30 pm »
    I didn't know they were the same...  Has your van got the 6 speed M32 gearbox in it then?

    Apart from changing the fluids and getting a garage to check the master & slave cylinders there's not a lot I can suggest.

    How many miles has the van done?  Is it on it's original clutch?


    Oh shoot i thought the Abarth had the 5 speed too  :-[ lol

    I took it to my friends garage but i just wanted to post on here too to get some more ideas as my mechanic is not sure whats causing it so a second opinion would be a help.

    Ive done 90,000kms with it and its still on its original clutch.

    Offline Shant Ole

    • S2000 Member
    • *****
    • Posts: 898
    • Carlo Rating: 1
      • Larnaca
    Re: Help - Gears not working properly
    « Reply #4 on: April 24, 2014, 04:45:01 pm »
    So have you renewed the gear change cables?

    If you have and they are adjusted correctly then the clutch would be next on the list.

    Does the clutch free off the drive when depressed ie. does it drag?

    Where is the bite point, on the floor or up high?

    As it's hydraulic and self adjusting, apart from bleeding, unless something is loose or leaking then it's replacement parts

    I have renewed the gear wire (not sure how exactly its called in English. It might indeed be the gear cable)

    Clutch feels normal and it bite very quick. As soon as i release the clutch it bites. Thats why im thinking it might not be the clutch and something else  ???

    Im guessing that the clutch pump might need to be replaced maybe?  ???

    Offline leroya500

    • Assetto Corse Member
    • ****
    • Posts: 492
    • Carlo Rating: 1
      • staffs
    Re: Help - Gears not working properly
    « Reply #5 on: April 24, 2014, 06:19:32 pm »
    Sounds like the synchromesh is toast mate

    Offline Shant Ole

    • S2000 Member
    • *****
    • Posts: 898
    • Carlo Rating: 1
      • Larnaca
    Re: Help - Gears not working properly
    « Reply #6 on: April 24, 2014, 06:22:14 pm »
    Sounds like the synchromesh is toast mate

    I hope its not something expensive to fix  :'(

    Offline leroya500

    • Assetto Corse Member
    • ****
    • Posts: 492
    • Carlo Rating: 1
      • staffs
    Re: Help - Gears not working properly
    « Reply #7 on: April 24, 2014, 06:44:36 pm »
    The part is normally pence, it's the labour that'll cost

    Anyway if it's a company car it's the company's problem

    Offline Shant Ole

    • S2000 Member
    • *****
    • Posts: 898
    • Carlo Rating: 1
      • Larnaca
    Re: Help - Gears not working properly
    « Reply #8 on: April 24, 2014, 07:03:58 pm »
    The part is normally pence, it's the labour that'll cost

    Anyway if it's a company car it's the company's problem

    Yes but the company is mine so i am going to pay for it  :P lol

    Offline leroya500

    • Assetto Corse Member
    • ****
    • Posts: 492
    • Carlo Rating: 1
      • staffs
    Re: Help - Gears not working properly
    « Reply #9 on: April 24, 2014, 07:07:53 pm »
    Ah! Maybe start looking for a cheap recon box? Normally around ala300 quid

    Offline Shant Ole

    • S2000 Member
    • *****
    • Posts: 898
    • Carlo Rating: 1
      • Larnaca
    Re: Help - Gears not working properly
    « Reply #10 on: April 24, 2014, 07:47:20 pm »
    Nahh i dont think i would want to change it at least at the moment. I will have a better look with my mechanic and see. We might find a solution :thumb:

     

    hungry