Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: Engine pinking  (Read 1788 times)

Offline Hawk

  • S2000 Member
  • *****
  • Posts: 537
  • Carlo Rating: 1
Engine pinking
« on: April 09, 2013, 10:19:06 pm »

Hi
My AGPSS has developed a 'pinking' noise over the last thousand miles or so.  Typical conditions for 'pinking' ie low rpm - high load.  Just wondered if anyone else had suffered the same and knew of the likely cause?

I've eliminated a few things like contaminated fuel (I always use either Vpower or momentum99 and have tried several different petrol stations).  I've also fitted new spark plugs.

Apart from the 'pinking' the car runs fine.  Any ideas would be most welcome. Cheers in advance  :thumb:

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline lloyd

    • S2000 Member
    • *****
    • Posts: 9336
    • Carlo Rating: 24
    Re: Engine pinking
    « Reply #1 on: April 09, 2013, 10:31:41 pm »
    not heard of this before, faulty sensor maybe?

    Offline Hawk

    • S2000 Member
    • *****
    • Posts: 537
    • Carlo Rating: 1
    Re: Engine pinking
    « Reply #2 on: April 09, 2013, 10:50:30 pm »
    not heard of this before, faulty sensor maybe?

    Hi Lloyd
    That's what I was thinking, well either that or an ECU fault.  Bit expensive to just guess and change parts, was hoping someone may be able to point me in the right direction. 

    I'll probably start with the crank sensor unless someone has a better idea . . . . . .

    Offline Johnaitken83

    • Newbie
    • *
    • Posts: 3
    • Carlo Rating: 0
      • County Durham
    Re: Engine pinking
    « Reply #3 on: May 04, 2020, 04:57:16 pm »
    Did you fix this?