Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: new part already!!  (Read 1143 times)

Offline maccy.

  • S2000 Member
  • *****
  • Posts: 504
  • Carlo Rating: 0
new part already!!
« on: January 09, 2009, 11:35:14 pm »
my car needs a new speedo surround! its perspex has rattled sinse I got it. had it in today and summit (a clip I think is broken)  :thumb:

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline Missing in Action

    • S2000 Member
    • *****
    • Posts: 2974
    • Carlo Rating: 0
    Re: new part already!!
    « Reply #1 on: January 09, 2009, 11:44:21 pm »
    thats a weird one! never heard that go wrong before abarth or fiat gp's ...

    you take it back to SG Petch?
    The one with the cape!

    Offline maccy.

    • S2000 Member
    • *****
    • Posts: 504
    • Carlo Rating: 0
    Re: new part already!!
    « Reply #2 on: January 11, 2009, 10:46:03 am »
    yeah, it has been like that since I got it

    Offline Missing in Action

    • S2000 Member
    • *****
    • Posts: 2974
    • Carlo Rating: 0
    Re: new part already!!
    « Reply #3 on: January 11, 2009, 11:35:41 am »
    hmmm very strange. oh well what can you do.  :-\
    The one with the cape!

    Offline 1mmortal

    • Assetto Corse Member
    • ****
    • Posts: 352
    • Carlo Rating: 0
    • "Moderately Cool" - as rated by AlexK
    Re: new part already!!
    « Reply #4 on: January 11, 2009, 04:56:21 pm »
    Yea, hopefully thats the ONLY prob.
    Ex-Abarthian BL08BLZ... GPA-SS (180) === Velocity Red Body/Charcoal Grey Wheels...

     

    hungry