Welcome, Guest. Please login or register.

Login with username, password and session length


Author Topic: Finally got one !  (Read 2110 times)

Offline darlo1969

  • Newbie
  • *
  • Posts: 4
  • Carlo Rating: 0
    • Cheshire
Finally got one !
« on: April 29, 2017, 09:06:02 pm »
After much umming & arring finally bit the bullet and got myself an A500.
He's a handsome brute, got a few options fitted. Interscope, chrome mirrors, xenon's, sky roof and the dimming rear view mirror thing.
Brought a smile to my face immediately, like going back 20 odd years. Not managed to get it pop between gears yet but I'm working on it, also B&M is connected to phone but can't make calls - media part working brilliantly though. Managed to get a s/h TMC but not fitted as yet so if anyone in Cheshire area fancies giving me some guidance it would be much appreciated. Having timing belt and w/pump fitted Tuesday , other than that not much to do . Though the front seat lever to tilt forward has snapped so may look at changing that, looks a ballache tbh ( common problem? )
Couple of questions.
How do I know what euro engine is fitted
Should I reset B&M - or can it lead to other problems

Anyway here's to many more " miles of smiles" (cheesey)

Adam

AbarthForum.co.uk

  • Advertisement
  • ***

    Offline curt595888

    • Abarth Wannabe
    • *
    • Posts: 47
    • Carlo Rating: 0
      • WSM
    Re: Finally got one !
    « Reply #1 on: April 30, 2017, 09:53:57 am »
    Welcome,  :wave:your new toy looks great, I am myself nearly signing on dotted line for a new factory order comp, enjoy your new purchase,  :thumb:

    Offline GTMartin

    • Administrator
    • S2000 Member
    • *****
    • Posts: 6220
    • Carlo Rating: 14
    Re: Finally got one !
    « Reply #2 on: April 30, 2017, 09:49:41 pm »
    Hi and welcome :wave:

    Try a phone hard reset, that sometimes does the trick.

    TMC box fitment, there are guides on youtube.

    Front seat lever can snap, but is not an over common problem.

    Later Euro ECUs are all black with no yellow parts on connectors.

    Offline tichwhat

    • Newbie
    • *
    • Posts: 3
    • Carlo Rating: 0
      • Cheshire
    Re: Finally got one !
    « Reply #3 on: May 29, 2017, 03:53:46 pm »
    I'm in Cheshire where abouts are you getting the timing belt done as mine is also needing this done and Fiat want £459 timing belt and water pump

    Offline darlo1969

    • Newbie
    • *
    • Posts: 4
    • Carlo Rating: 0
      • Cheshire
    Re: Finally got one !
    « Reply #4 on: May 31, 2017, 12:10:38 am »
    Rudheath MOT centre in Northwich, £300 for belt & pump Inc labour. It was a Gates one they fitted

     

    hungry